aboutsummaryrefslogtreecommitdiffstats
path: root/community/packer/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/packer/APKBUILD')
-rw-r--r--community/packer/APKBUILD36
1 files changed, 0 insertions, 36 deletions
diff --git a/community/packer/APKBUILD b/community/packer/APKBUILD
deleted file mode 100644
index f57b138fc34..00000000000
--- a/community/packer/APKBUILD
+++ /dev/null
@@ -1,36 +0,0 @@
-# Maintainer: Galen Abell <galen@galenabell.com>
-# Contributor: Galen Abell <galen@galenabell.com>
-pkgname=packer
-pkgver=1.7.2
-pkgrel=1
-pkgdesc="tool for creating machine images for multiple platforms"
-url="https://www.packer.io/"
-license="MPL-2.0"
-arch="all"
-makedepends="go"
-source="$pkgname-$pkgver.tar.gz::https://github.com/hashicorp/packer/archive/v$pkgver.tar.gz"
-
-export GOFLAGS="$GOFLAGS -trimpath -mod=readonly -modcacherw"
-export GO111MODULE=auto
-export GOPATH="$srcdir"
-export GOLDFLAGS="-s -w -X main.GitCommit=v$pkgver"
-
-build() {
- go build -v -o bin/$pkgname
-}
-
-check() {
- go list -mod=vendor . | xargs -t -n4 go test -mod=vendor -timeout=2m -parallel=4
- bin/$pkgname -v
-}
-
-package() {
- install -Dm755 bin/"$pkgname" -t "$pkgdir"/usr/bin/
-}
-
-cleanup_srcdir() {
- go clean -modcache
- default_cleanup_srcdir
-}
-
-sha512sums="019bd07571ca59cb8fbf6edb5dc7f57af11c43b144986222c3d560a812f25d61bbc87a554963eea479f8bfe61abacca7173c4f12b1bc09ffaf78c269624c826e packer-1.7.2.tar.gz"