aboutsummaryrefslogtreecommitdiffstats
path: root/community/pamixer/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/pamixer/APKBUILD')
-rw-r--r--community/pamixer/APKBUILD25
1 files changed, 14 insertions, 11 deletions
diff --git a/community/pamixer/APKBUILD b/community/pamixer/APKBUILD
index 30a81f562ee..66a6fd577f7 100644
--- a/community/pamixer/APKBUILD
+++ b/community/pamixer/APKBUILD
@@ -1,27 +1,30 @@
# Contributor: Alex McGrath <amk@amk.ie>
# Maintainer: Alex McGrath <amk@amk.ie>
pkgname=pamixer
-pkgver=1.5
-pkgrel=2
+pkgver=1.6
+pkgrel=0
pkgdesc="pulseaudio command line mixer"
url="https://github.com/cdemoulins/pamixer"
arch="all"
license="GPL-3.0-only"
-makedepends="pulseaudio-dev boost-dev"
-source="$pkgname-$pkgver.tar.gz::https://github.com/cdemoulins/pamixer/archive/$pkgver.tar.gz"
-# tests disabled as there are none
-options="!check"
+makedepends="
+ cxxopts-dev
+ meson
+ pulseaudio-dev
+ "
+subpackages="$pkgname-doc"
+source="https://github.com/cdemoulins/pamixer/archive/$pkgver/$pkgname-$pkgver.tar.gz"
+options="!check" # no tests provided
build() {
- export CXXFLAGS="$CXXFLAGS -DVERSION=$pkgver"
- make
+ abuild-meson . output
+ meson compile -j ${JOBS:-0} -C output
}
package() {
- install -Dm755 "$builddir"/"$pkgname" \
- "$pkgdir"/usr/bin/"$pkgname"
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
sha512sums="
-f520e43efcf77332b26d444529d8e706256fda2a497d5c4f694c074abda118f70d82f7f87f9cd1f1f52e19f84d51484cb00ec58ece458106cef40edac8b39d3c pamixer-1.5.tar.gz
+c01b7c4184901955bff82aaeef0cde7f0b613e6ebff1158b3603f2835e13590a9353920a430598a3cde5c305a7316a78e302186bf4d3bf458133262578b42eb3 pamixer-1.6.tar.gz
"