aboutsummaryrefslogtreecommitdiffstats
path: root/community/pamixer
diff options
context:
space:
mode:
Diffstat (limited to 'community/pamixer')
-rw-r--r--community/pamixer/APKBUILD24
1 files changed, 15 insertions, 9 deletions
diff --git a/community/pamixer/APKBUILD b/community/pamixer/APKBUILD
index 4660e46af64..3221e441f72 100644
--- a/community/pamixer/APKBUILD
+++ b/community/pamixer/APKBUILD
@@ -1,24 +1,30 @@
# Contributor: Alex McGrath <amk@amk.ie>
# Maintainer: Alex McGrath <amk@amk.ie>
pkgname=pamixer
-pkgver=1.4
+pkgver=1.6
pkgrel=1
pkgdesc="pulseaudio command line mixer"
url="https://github.com/cdemoulins/pamixer"
arch="all"
license="GPL-3.0-only"
-makedepends="pulseaudio-dev boost-dev"
-source="$pkgname-$pkgver.tar.gz::https://github.com/cdemoulins/pamixer/archive/$pkgver.tar.gz"
-# tests disabled as there are none
-options="!check"
+makedepends="
+ cxxopts-dev
+ meson
+ pulseaudio-dev
+ "
+subpackages="$pkgname-doc"
+source="https://github.com/cdemoulins/pamixer/archive/$pkgver/$pkgname-$pkgver.tar.gz"
+options="!check" # no tests provided
build() {
- make
+ abuild-meson . output
+ meson compile -j ${JOBS:-0} -C output
}
package() {
- install -Dm755 "$builddir"/"$pkgname" \
- "$pkgdir"/usr/bin/"$pkgname"
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-sha512sums="e3916ed8dc020bb43e57994a9f35a506147a0fde42b88c30c661cbeffa40e0f74cae66cd015394e524684c32f9674de3e3763a1396a3e1b9aecbfdc3ed117fe4 pamixer-1.4.tar.gz"
+sha512sums="
+c01b7c4184901955bff82aaeef0cde7f0b613e6ebff1158b3603f2835e13590a9353920a430598a3cde5c305a7316a78e302186bf4d3bf458133262578b42eb3 pamixer-1.6.tar.gz
+"