aboutsummaryrefslogtreecommitdiffstats
path: root/community/pangomm2.48/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/pangomm2.48/APKBUILD')
-rw-r--r--community/pangomm2.48/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/community/pangomm2.48/APKBUILD b/community/pangomm2.48/APKBUILD
new file mode 100644
index 00000000000..76356f1a644
--- /dev/null
+++ b/community/pangomm2.48/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=pangomm2.48
+pkgver=2.50.1
+pkgrel=2
+pkgdesc="C++ bindings for pango"
+#options="!check" # No testsuite
+url="https://www.gtkmm.org/"
+arch="all"
+license="LGPL-2.1-or-later AND GPL-2.0-or-later"
+makedepends="meson pango-dev glibmm2.68-dev cairomm1.16-dev"
+subpackages="$pkgname-dev"
+source="https://download.gnome.org/sources/pangomm/${pkgver%.*}/pangomm-$pkgver.tar.xz"
+builddir="$srcdir/pangomm-$pkgver"
+
+build() {
+ abuild-meson -Db_lto=true . output
+ meson compile -C output
+}
+
+check() {
+ meson test --no-rebuild --print-errorlogs -C output
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
+}
+
+sha512sums="
+bffc55eedc4f278480a74afcf119b79a295bf5775123f582746ba425e19e2690d627baa9a9813b70db9e063db7efe959f365567dd7bcbc1fc862212ba8225a98 pangomm-2.50.1.tar.xz
+"