aboutsummaryrefslogtreecommitdiffstats
path: root/community/parley/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/parley/APKBUILD')
-rw-r--r--community/parley/APKBUILD32
1 files changed, 18 insertions, 14 deletions
diff --git a/community/parley/APKBUILD b/community/parley/APKBUILD
index 8ba778f88e3..4acf612c154 100644
--- a/community/parley/APKBUILD
+++ b/community/parley/APKBUILD
@@ -1,11 +1,14 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=parley
-pkgver=21.08.2
+pkgver=24.02.2
pkgrel=0
# armhf blocked by extra-cmake-modules
-# ppc64le, s390x, mips64 and riscv64 blocked by qt5-qtwebengine
-arch="all !armhf !ppc64le !s390x !mips64 !riscv64"
+# armv7, ppc64le, s390x and riscv64 blocked by qt6-qtwebengine
+arch="all !armhf !armv7 !ppc64le !s390x !riscv64"
url="https://kde.org/applications/education/org.kde.parley"
pkgdesc="Vocabulary Trainer"
license="GPL-2.0-or-later AND GFDL-1.2-only"
@@ -20,31 +23,32 @@ makedepends="
kio-dev
knewstuff-dev
knotifications-dev
- kross-dev
kxmlgui-dev
libkeduvocdocument-dev
libxml2-dev
libxslt-dev
- qt5-qtbase-dev
- qt5-qtmultimedia-dev
- qt5-qtwebengine-dev
+ qt6-qtbase-dev
+ qt6-qtmultimedia-dev
+ qt6-qtsvg-dev
+ qt6-qtwebengine-dev
+ samurai
sonnet-dev
"
checkdepends="xvfb-run"
-source="https://download.kde.org/stable/release-service/$pkgver/src/parley-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/education/parley.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/parley-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest
+ xvfb-run ctest --test-dir build --output-on-failure
}
package() {
@@ -52,5 +56,5 @@ package() {
}
sha512sums="
-bd5371f42394d9b53c3d67fc8ee96836903d0643d93c9f63fa3d761beda50bc0d67e9b90c81746ab24e947a9e776aebaac80ebdb4244677de8aa3558772b4ef4 parley-21.08.2.tar.xz
+afdb8829fffed2c54863c120299464b70acfc77706125246c12c90a90ebf58dd3002390b6560012d6a92d72f3d74c29717adbc8f33fd858cfcbd93b0b13b122e parley-24.02.2.tar.xz
"