aboutsummaryrefslogtreecommitdiffstats
path: root/community/partclone/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/partclone/APKBUILD')
-rw-r--r--community/partclone/APKBUILD47
1 files changed, 26 insertions, 21 deletions
diff --git a/community/partclone/APKBUILD b/community/partclone/APKBUILD
index 3e258cdceb0..45a85a938ad 100644
--- a/community/partclone/APKBUILD
+++ b/community/partclone/APKBUILD
@@ -1,44 +1,46 @@
# Contributor: Sean McAvoy <seanmcavoy@gmail.com>
# Maintainer: Sean McAvoy <seanmcavoy@gmail.com>
pkgname=partclone
-pkgver=0.3.20
+pkgver=0.3.27
pkgrel=0
pkgdesc="utilities to save and restore used blocks on a partition"
url="https://partclone.org"
arch="all"
license="GPL-2.0-only"
makedepends="
- e2fsprogs-dev
+ autoconf
+ automake
+ bash
btrfs-progs-dev
- ntfs-3g-dev
+ diffutils
+ docbook-xml
+ e2fsprogs-dev
f2fs-tools-dev
+ gettext-dev
hfsprogs
- ncurses-dev
- automake
- autoconf
- libxslt-dev
- docbook-xml
- libtool
intltool
- gettext-dev
+ libtool
+ libxslt-dev
+ ncurses-dev
+ ntfs-3g-dev
openssl-dev
- diffutils
- coreutils
- bash
"
subpackages="$pkgname-doc $pkgname-lang"
source="https://github.com/Thomas-Tsai/partclone/archive/$pkgver/partclone-$pkgver.tar.gz
musl.patch
+ remove-usage-of-off64_t.patch
+ very-funny-glibc-types.patch
"
-if [ "$CARCH" = "riscv64" ]; then
- options="$options textrels"
-fi
+prepare() {
+ default_prepare
+ autoreconf -fvi
+}
build() {
- autoreconf -vif
# xfs seems broken right now :(
- LIBS="-lintl" ./configure --prefix=/usr \
+ LIBS="-lintl" ./configure \
+ --prefix=/usr \
--disable-rpath \
--enable-ncursesw \
--enable-fat \
@@ -48,7 +50,8 @@ build() {
--enable-btrfs \
--enable-minix \
--enable-f2fs \
- --enable-hfsp
+ --enable-hfsp \
+ --enable-xfs
make
}
check() {
@@ -61,6 +64,8 @@ package() {
}
sha512sums="
-32dced369973c39412c562ab8731ff7b490f464b5ed4033456e6b23f3f79c437f43dc9db4c79b4821f35e4997d1444c8d80c53816b2a3bb90836fb5ad33b368e partclone-0.3.20.tar.gz
-0676b34c5818f8866e733b0aee151e8220b8db839ba732acfdaad4dcea81a4b5d514a520e43c79efcf53ba0788c9a7f06c043441b4d1f56dd684882329efce9d musl.patch
+a048bf79c499826b477247a5199f2cde23b372ad07368c142380eafb62c1c6054db7c0d6d1643f7e8c25cbccb8c83cb7ff10e79a6337e5df558bbb061aca2174 partclone-0.3.27.tar.gz
+67505eda6028a772700ab776faa4f3156deec205525aa83b76b43917d4b2bf7704d6c15e44da96f19e23b856669285ff94f5bc71c9bbac75b30b0831ebc95576 musl.patch
+3c48851e3848f33bc257859febb54569dc00006af9877b706da5adca5680d61ee6291b62511ee1d50fb07d82cc04bffa5074ef5825071407570b952ff06684ef remove-usage-of-off64_t.patch
+16877cba85c0f2505940b88bf60b146b5412e624ab48733a5c9b1094f0a3ce031f8d3b5fd9aecd82fba6787f6939ae48fb713181d54db92990ff7b83e3b961c9 very-funny-glibc-types.patch
"