aboutsummaryrefslogtreecommitdiffstats
path: root/community/partitionmanager/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/partitionmanager/APKBUILD')
-rw-r--r--community/partitionmanager/APKBUILD25
1 files changed, 14 insertions, 11 deletions
diff --git a/community/partitionmanager/APKBUILD b/community/partitionmanager/APKBUILD
index 7bb111b812d..aa950a2f16c 100644
--- a/community/partitionmanager/APKBUILD
+++ b/community/partitionmanager/APKBUILD
@@ -1,11 +1,13 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=partitionmanager
-pkgver=21.08.1
+pkgver=24.02.2
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+arch="all !armhf"
url="https://kde.org/applications/system/org.kde.partitionmanager"
pkgdesc="A KDE utility that allows you to manage disks, partitions, and file systems"
license="GPL-3.0-or-later"
@@ -24,22 +26,23 @@ makedepends="
kpmcore-dev
kwidgetsaddons-dev
kxmlgui-dev
- qt5-qtbase-dev
+ qt6-qtbase-dev
+ samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/partitionmanager-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/system/partitionmanager.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/partitionmanager-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -47,5 +50,5 @@ package() {
}
sha512sums="
-11f23c9444f46489b9bf691d9ac1522f665a165d4503524aaa955e11966e6a4230021ed6f661878b30cfa0143b5efcc8676048625b3b2a79eea36051477bb2ae partitionmanager-21.08.1.tar.xz
+53694c88828fe83a5e29dd1af6e20d48f4670a4925457ff15f640b5e1d457b1c2fcf266dd358163e2e1b72bd69b570d72dcde9adb8ef9e610666f6bb74eb7094 partitionmanager-24.02.2.tar.xz
"