aboutsummaryrefslogtreecommitdiffstats
path: root/community/partitionmanager/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/partitionmanager/APKBUILD')
-rw-r--r--community/partitionmanager/APKBUILD20
1 files changed, 11 insertions, 9 deletions
diff --git a/community/partitionmanager/APKBUILD b/community/partitionmanager/APKBUILD
index 3813d750c50..aa950a2f16c 100644
--- a/community/partitionmanager/APKBUILD
+++ b/community/partitionmanager/APKBUILD
@@ -1,11 +1,13 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=partitionmanager
-pkgver=22.04.2
+pkgver=24.02.2
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !riscv64"
+arch="all !armhf"
url="https://kde.org/applications/system/org.kde.partitionmanager"
pkgdesc="A KDE utility that allows you to manage disks, partitions, and file systems"
license="GPL-3.0-or-later"
@@ -24,11 +26,12 @@ makedepends="
kpmcore-dev
kwidgetsaddons-dev
kxmlgui-dev
- qt5-qtbase-dev
+ qt6-qtbase-dev
samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/partitionmanager-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/system/partitionmanager.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/partitionmanager-$pkgver.tar.xz"
build() {
cmake -B build -G Ninja \
@@ -39,8 +42,7 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -48,5 +50,5 @@ package() {
}
sha512sums="
-09715df9012b5dab83ce635ca1d2e90e13455a1b798fc1c0a260dbfbc85a48d41db2a96652abc4b8d97a0128c292d360208ce0a6763a4ba5c19963dffc16af42 partitionmanager-22.04.2.tar.xz
+53694c88828fe83a5e29dd1af6e20d48f4670a4925457ff15f640b5e1d457b1c2fcf266dd358163e2e1b72bd69b570d72dcde9adb8ef9e610666f6bb74eb7094 partitionmanager-24.02.2.tar.xz
"