aboutsummaryrefslogtreecommitdiffstats
path: root/community/pass-git-helper/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/pass-git-helper/APKBUILD')
-rw-r--r--community/pass-git-helper/APKBUILD23
1 files changed, 16 insertions, 7 deletions
diff --git a/community/pass-git-helper/APKBUILD b/community/pass-git-helper/APKBUILD
index b39ef54e943..0873de27384 100644
--- a/community/pass-git-helper/APKBUILD
+++ b/community/pass-git-helper/APKBUILD
@@ -1,29 +1,38 @@
# Contributor: Galen Abell <galen@galenabell.com>
# Maintainer: Galen Abell <galen@galenabell.com>
pkgname=pass-git-helper
-pkgver=1.1.1
+pkgver=1.4.0
pkgrel=2
pkgdesc="git credential helper interfacing with pass, the standard unix password manager."
url="https://github.com/languitar/pass-git-helper"
arch="noarch"
license="LGPL-3.0-only"
-depends="python3 pass py3-xdg"
-makedepends="py3-setuptools"
+depends="python3 py3-xdg"
+makedepends="py3-gpep517 py3-setuptools py3-wheel"
checkdepends="py3-pytest py3-pytest-cov py3-pytest-mock"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/languitar/pass-git-helper/archive/v$pkgver.tar.gz"
provides="py3-pass-git-helper=$pkgver-r$pkgrel"
replaces="py3-pass-git-helper"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 setup.py test
+ python3 -m venv --clear --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="94e2fbc279682c4487ead20f3b2d91b49b3f69c73de63b71b42800d304e9cec7be5016b207587fb2ecd07f3f2adbfc63d29d7ad28c79ba90a3ebc35523cc7939 pass-git-helper-1.1.1.tar.gz"
+
+sha512sums="
+a4f16dd73bd2d4e2070691aa7cff98ca8ebb73d981401873c6aca4654f475958cf7a51c6f2bdb1f7f030ae41ddad28055d82dab3f6fe220ed467f68408fc6c77 pass-git-helper-1.4.0.tar.gz
+"