aboutsummaryrefslogtreecommitdiffstats
path: root/community/pass-otp/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/pass-otp/APKBUILD')
-rw-r--r--community/pass-otp/APKBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/community/pass-otp/APKBUILD b/community/pass-otp/APKBUILD
index 3d398daf409..d58afc149af 100644
--- a/community/pass-otp/APKBUILD
+++ b/community/pass-otp/APKBUILD
@@ -8,9 +8,10 @@ url="https://github.com/tadfisher/pass-otp"
arch="noarch"
license="GPL-3.0-only"
depends="pass libqrencode oath-toolkit-oathtool"
-checkdepends="git expect"
+checkdepends="git expect gnupg"
subpackages="$pkgname-doc $pkgname-bash-completion"
source="pass-otp-$pkgver.tar.gz::https://github.com/tadfisher/pass-otp/archive/v$pkgver.tar.gz"
+options="!check" # fails due to old version
check() {
make test
@@ -19,4 +20,6 @@ check() {
package() {
make DESTDIR="$pkgdir" BASHCOMPDIR="/usr/share/bash-completion/completions" install
}
-sha512sums="3d1417462998750ef1580169ed0e4b721b5f430cd86a678d1b6bc7b2ac123879902f7d22c28dc21e8a171ec80dfc51b6465d0dcc78cb009eb731651f2cb152f5 pass-otp-1.2.0.tar.gz"
+sha512sums="
+3d1417462998750ef1580169ed0e4b721b5f430cd86a678d1b6bc7b2ac123879902f7d22c28dc21e8a171ec80dfc51b6465d0dcc78cb009eb731651f2cb152f5 pass-otp-1.2.0.tar.gz
+"