aboutsummaryrefslogtreecommitdiffstats
path: root/community/patchwork/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/patchwork/APKBUILD')
-rw-r--r--community/patchwork/APKBUILD60
1 files changed, 21 insertions, 39 deletions
diff --git a/community/patchwork/APKBUILD b/community/patchwork/APKBUILD
index bbed83733b8..7f4c9ba102e 100644
--- a/community/patchwork/APKBUILD
+++ b/community/patchwork/APKBUILD
@@ -1,8 +1,8 @@
# Con#tributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=patchwork
-pkgver=2.1.4
-pkgrel=1
+pkgver=3.1.3
+pkgrel=0
pkgdesc="Web-based patch tracking system"
url="https://github.com/getpatchwork/patchwork"
arch="noarch"
@@ -19,20 +19,14 @@ subpackages="
$pkgname-doc
$pkgname-uwsgi-apache2:apache2_wsgi
$pkgname-uwsgi-nginx:nginx_wsgi
- $pkgname-mysql
- $pkgname-postgresql
- pwclient:pwclient
"
source="patchwork-$pkgver.tar.gz::https://github.com/getpatchwork/patchwork/archive/v$pkgver.tar.gz
- dependencies-fix.patch
0001-support-busybox-readlink.patch
0002-remove-uneeded-bashism-from-tools-and-change-path.patch
nginx-uwsgi-patchwork-conf.ini
nginx-patchwork.conf
- py-django-rest-framwork-py-django-filter.patch
"
-
# secfixes:
# 2.0.1-r1:
# - CVE-2019-13122
@@ -44,9 +38,17 @@ package() {
rm -f COPYING
install -Dm644 patchwork/settings/production.example.py \
"$pkgdir"/etc/$pkgname/production.py
- mv * "$pkgdir"/usr/share/webapps/$pkgname
+
+ mv ./* "$pkgdir"/usr/share/webapps/$pkgname
cd "$pkgdir"/usr/share/webapps/patchwork/patchwork/settings
- ln -sf /etc/patchwork/production.py
+ ln -sf ../../../../../../etc/patchwork/production.py production.py
+
+ install -Dm644 "$srcdir"/nginx-patchwork.conf \
+ "$pkgdir"/etc/nginx/conf.d/patchwork.conf
+ install -Dm644 "$srcdir"/nginx-uwsgi-patchwork-conf.ini \
+ "$pkgdir"/etc/uwsgi/conf.d/patchwork.ini
+ install -Dm644 "$pkgdir"/usr/share/webapps/patchwork/lib/apache2/patchwork.wsgi.conf \
+ "$pkgdir"/etc/apache2/conf.d/patchwork.wsgi.conf
}
apache2_wsgi() {
@@ -54,44 +56,24 @@ apache2_wsgi() {
depends="apache2 apache2-mod-wsgi"
replaces="$pkgname-apache2-wsgi"
install_if="$pkgname=$pkgver-r$pkgrel apache2-mod-wsgi"
- install -Dm644 "$pkgdir"/usr/share/webapps/patchwork/lib/apache2/patchwork.wsgi.conf \
- "$subpkgdir"/etc/apache2/conf.d/patchwork.wsgi.conf
+
+ amove etc/apache2/conf.d/patchwork.wsgi.conf
}
nginx_wsgi() {
pkgdesc="$pkgname nginx wsgi support"
depends="nginx uwsgi-python"
replaces="$pkgname-nginx_wsgi"
- install_if="nginx patchwork uwsgi"
- install -Dm644 "$srcdir"/nginx-patchwork.conf \
- "$subpkgdir"/etc/nginx/conf.d/patchwork.conf
- install -Dm644 "$srcdir"/nginx-uwsgi-patchwork-conf.ini \
- "$subpkgdir"/etc/uwsgi/conf.d/patchwork.ini
-}
-
-mysql() {
- pkgdesc="$pkgname mysql support"
- depends="py-mysqldb"
- mkdir -p "$subpkgdir"
-}
-
-postgresql() {
- pkgdesc="$pkgname postgresql support"
- depends="py-psycopg2"
- mkdir -p "$subpkgdir"
-}
+ install_if="$pkgname=$pkgver-r$pkgrel nginx uwsgi"
-pwclient() {
- pkgdesc="command-line client for patchwork"
- depends="python2"
- install -Dm775 "$pkgdir"/usr/share/webapps/patchwork/patchwork/bin/pwclient \
- "$subpkgdir"/usr/bin/pwclient
+ amove etc/nginx/conf.d/patchwork.conf
+ amove etc/uwsgi/conf.d/patchwork.ini
}
-sha512sums="e15e1b2b9d386d98f74d55efcc805ecad827be40610c993245d3ac13d04b655a264bf0ebe7ec83b929db52059a9dd13c49bd56676a5c1d2f25d965b310bccfb0 patchwork-2.1.4.tar.gz
-1721531735c02d2f3d0241341ffe4620c66771cf99fb9b597156bcc3b19b5cdfd17835d4e79f2fdfef33c1f3bf13444174b3fb0c9363520574918d924dae454c dependencies-fix.patch
+sha512sums="
+7aeef84cf581b0a9cd24feee2107b4a3bc93b6c8d6579590fbe2a091253f22675abbda4c2061b2daa9c201f3a7254828d0940a46fbbb64c60e96897ee4024fa3 patchwork-3.1.3.tar.gz
5facc2c2620b2d614011bcdc06bb481fb1481c79333579e5a7fa5b8bc4f97d1651cc8c4632a5e150b62674d64c00345341229319f1edb2016721868e84146826 0001-support-busybox-readlink.patch
-f6d3590b3ac53797e0ae25fe50ab0935608be5ded44665599cbc91e93558895eddc6a7a717153d81fc194b314d7854686577ef5ecf9e0302b7824ce3b3863f7b 0002-remove-uneeded-bashism-from-tools-and-change-path.patch
+432b7981679499183ebb5ad8caa560a059ba11bad1e6489256f2a44808846110a1aaf08728509869cb0d898514b4368f8924316e7bde9d5f5db2ffea7d471813 0002-remove-uneeded-bashism-from-tools-and-change-path.patch
28911a25e00a254237f7214fb681e5e984a2eae331e610be62967d5e246958e0f8d3f84861d8fd17c1190c1df72a25f28ddb33843b3679a3864beb00cb4b4961 nginx-uwsgi-patchwork-conf.ini
862dd2522236a0b18d2a8d06f1ad91ad0fd0936fa502d95e09556641e67d42e1212821bfd7fb98923e4fe8b8a7369ded8c23831fb496b1e2833d9831c1b23725 nginx-patchwork.conf
-5f1d5189bde5ba4494aec3e9517583a58791f50632c67b5e17a05cd2b9beaef02b5c12dfbb7d076e8af49c5dffe6fb3f4739897a58a2c7d2915baf19fb26c4fc py-django-rest-framwork-py-django-filter.patch"
+"