aboutsummaryrefslogtreecommitdiffstats
path: root/community/patchwork/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/patchwork/APKBUILD')
-rw-r--r--community/patchwork/APKBUILD11
1 files changed, 2 insertions, 9 deletions
diff --git a/community/patchwork/APKBUILD b/community/patchwork/APKBUILD
index 9783668cdac..023963ba477 100644
--- a/community/patchwork/APKBUILD
+++ b/community/patchwork/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=patchwork
pkgver=2.1.5
-pkgrel=0
+pkgrel=1
pkgdesc="Web-based patch tracking system"
url="https://github.com/getpatchwork/patchwork"
arch="noarch"
@@ -19,7 +19,6 @@ subpackages="
$pkgname-doc
$pkgname-uwsgi-apache2:apache2_wsgi
$pkgname-uwsgi-nginx:nginx_wsgi
- $pkgname-postgresql
pwclient:pwclient
"
source="patchwork-$pkgver.tar.gz::https://github.com/getpatchwork/patchwork/archive/v$pkgver.tar.gz
@@ -61,19 +60,13 @@ nginx_wsgi() {
pkgdesc="$pkgname nginx wsgi support"
depends="nginx uwsgi-python"
replaces="$pkgname-nginx_wsgi"
- install_if="nginx patchwork uwsgi"
+ install_if="$pkgname=$pkgver-r$pkgrel nginx uwsgi"
install -Dm644 "$srcdir"/nginx-patchwork.conf \
"$subpkgdir"/etc/nginx/conf.d/patchwork.conf
install -Dm644 "$srcdir"/nginx-uwsgi-patchwork-conf.ini \
"$subpkgdir"/etc/uwsgi/conf.d/patchwork.ini
}
-postgresql() {
- pkgdesc="$pkgname postgresql support"
- depends="py-psycopg2"
- mkdir -p "$subpkgdir"
-}
-
pwclient() {
pkgdesc="command-line client for patchwork"
depends="python3"