aboutsummaryrefslogtreecommitdiffstats
path: root/community/pcmanfm-qt/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/pcmanfm-qt/APKBUILD')
-rw-r--r--community/pcmanfm-qt/APKBUILD19
1 files changed, 12 insertions, 7 deletions
diff --git a/community/pcmanfm-qt/APKBUILD b/community/pcmanfm-qt/APKBUILD
index 3335422892f..61313524431 100644
--- a/community/pcmanfm-qt/APKBUILD
+++ b/community/pcmanfm-qt/APKBUILD
@@ -1,15 +1,20 @@
# Maintainer: Antoni Aloy <aaloytorrens@gmail.com>
pkgname=pcmanfm-qt
-pkgver=1.1.0
+pkgver=1.4.1
pkgrel=0
pkgdesc="Qt port of pcmanfm"
url="https://github.com/lxqt/pcmanfm-qt"
-arch="all !s390x !armhf" # s390x blocked by libfm-qt
+arch="all !armhf"
license="LGPL-2.0-or-later"
-depends="desktop-file-utils paper-icon-theme lxmenu-data"
+depends="desktop-file-utils lxqt-menu-data"
makedepends="
- cmake samurai lxqt-build-tools menu-cache-dev
- qt5-qttools-dev libfm-qt-dev libexif-dev
+ cmake
+ libexif-dev
+ libfm-qt-dev
+ lxqt-build-tools
+ menu-cache-dev
+ qt5-qttools-dev
+ samurai
"
subpackages="$pkgname-doc $pkgname-lang"
source="https://github.com/lxqt/pcmanfm-qt/releases/download/$pkgver/pcmanfm-qt-$pkgver.tar.xz"
@@ -23,7 +28,7 @@ build() {
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_SHARED_LIBS=True \
- $CMAKE_CROSSOPTS .
+ $CMAKE_CROSSOPTS
cmake --build build
}
@@ -37,5 +42,5 @@ lang() {
}
sha512sums="
-b453b56bd10a94b6c4cbf6e999a470208c7817384f3868ef230a65d39ff3b1e2b2e6db8c08ca894c4e226288efd38dbdddeb1294fa4f8507836cf84594b956ef pcmanfm-qt-1.1.0.tar.xz
+3c0186ba2defe3ce440345bfe17635613e9fa2a511dc8309810799cbac931266ea9a42a9a3ebed7bd7bb2f7ec4383dc7d1526b7c689424c5aefcc295bfa2845d pcmanfm-qt-1.4.1.tar.xz
"