aboutsummaryrefslogtreecommitdiffstats
path: root/community/pdfgrep/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/pdfgrep/APKBUILD')
-rw-r--r--community/pdfgrep/APKBUILD16
1 files changed, 7 insertions, 9 deletions
diff --git a/community/pdfgrep/APKBUILD b/community/pdfgrep/APKBUILD
index 908f817a7d3..63e0c51d5ab 100644
--- a/community/pdfgrep/APKBUILD
+++ b/community/pdfgrep/APKBUILD
@@ -2,23 +2,21 @@
# Contributor: André Klitzing <aklitzing@gmail.com>
# Maintainer: André Klitzing <aklitzing@gmail.com>
pkgname=pdfgrep
-pkgver=2.1.2
-pkgrel=2
+pkgver=2.2.0
+pkgrel=0
pkgdesc="Commandline utility to search text in PDF files"
url="https://pdfgrep.org/"
arch="all"
-license="GPL"
+license="GPL-2.0-or-later"
makedepends="autoconf automake pcre-dev poppler-dev libgcrypt-dev"
checkdepends="dejagnu texlive"
subpackages="$pkgname-doc
$pkgname-zsh-completion:zshcomp:noarch
$pkgname-bash-completion:bashcomp:noarch"
-source="https://pdfgrep.org/download/${pkgname}-${pkgver}.tar.gz"
+source="https://pdfgrep.org/download/$pkgname-$pkgver.tar.gz"
options="!check" # multiple failures
-builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -30,12 +28,10 @@ build() {
}
check() {
- cd "$builddir"
make -k check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
@@ -59,4 +55,6 @@ zshcomp() {
"$subpkgdir"/usr/share/zsh/site-functions
}
-sha512sums="27bc4741e5203b2fd265815a22ad8d702b3455b2ae932641b040fc9ce615bc9ff0abef221eb2ec8aa59c79cb139d31184261d076f9731177129a473d62aa4e5c pdfgrep-2.1.2.tar.gz"
+sha512sums="
+de39ccb266f30b32ec71083759553979a31f7220b4923a4c3c74e1001c2f2c0dbef17c00f8139ffe88eec2031c48a13f18a057c7523ad363689b0f5b004c420f pdfgrep-2.2.0.tar.gz
+"