aboutsummaryrefslogtreecommitdiffstats
path: root/community/pdns/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/pdns/APKBUILD')
-rw-r--r--community/pdns/APKBUILD9
1 files changed, 8 insertions, 1 deletions
diff --git a/community/pdns/APKBUILD b/community/pdns/APKBUILD
index 992c760b22b..09abbfab429 100644
--- a/community/pdns/APKBUILD
+++ b/community/pdns/APKBUILD
@@ -94,13 +94,20 @@ tools() {
done; unset -v _tool
}
-_mv_backend() {
+_backend() {
local backend=$1
shift
pkgdesc="$backend backend module for PowerDNS"
depends="$pkgname $*"
+ mkdir -p "$subpkgdir"
+}
+
+_mv_backend() {
+ local backend=$1
+ _backend "$@"
+
mkdir -p "$subpkgdir/usr/lib/pdns/pdns"
mv "$pkgdir/usr/lib/pdns/pdns/lib${backend}backend.so" \
"$subpkgdir/usr/lib/pdns/pdns/"