aboutsummaryrefslogtreecommitdiffstats
path: root/community/pdns
diff options
context:
space:
mode:
Diffstat (limited to 'community/pdns')
-rw-r--r--community/pdns/APKBUILD12
-rw-r--r--community/pdns/pdns-boost-containers-exceptions.patch45
2 files changed, 6 insertions, 51 deletions
diff --git a/community/pdns/APKBUILD b/community/pdns/APKBUILD
index fece7d75ebe..ef6c181d1f5 100644
--- a/community/pdns/APKBUILD
+++ b/community/pdns/APKBUILD
@@ -4,10 +4,10 @@
# Contributor: Olivier Mauras <olivier@mauras.ch>
# Contributor: Daniel Isaksen <d@duniel.no>
# Contributor: Fabian Zoske <fabian@zoske.it>
-# Maintainer: Matt Smith <mcs@darkregion.net>
+# Maintainer: Peter van Dijk <peter.van.dijk@powerdns.com>
pkgname=pdns
-pkgver=4.4.1
-pkgrel=6
+pkgver=4.5.1
+pkgrel=0
pkgdesc="PowerDNS Authoritative Server"
url="https://www.powerdns.com/"
# aarch64 blocked by broken luajit userdata
@@ -39,7 +39,6 @@ pkggroups="pdns"
source="https://downloads.powerdns.com/releases/pdns-$pkgver.tar.bz2
$pkgname.initd
$pkgname.conf
- pdns-boost-containers-exceptions.patch
"
# secfixes:
@@ -154,7 +153,8 @@ backend_pgsql() {
mv "$pkgdir/etc/$pkgname/4.1.0_to_4.2.0_schema.pgsql.sql" "$subpkgdir/etc/$pkgname/"
}
-sha512sums="a6f31972f77ded8ecfb523e8810dd90e5b7aa628746fee2a9a0daae2a7935800f111ce8617ffd71d5ce3881947d4ffc36c9cb37996a7bcc514536bb4abe1f79e pdns-4.4.1.tar.bz2
+sha512sums="
+428be2bea0d39613fe31def9116c0d3dbfc95eac953ca058df088f06a971a5a1a49067f83c99719af2657e7abcf2e7c471311bd26a1ebf1bae2bd70e1a823fca pdns-4.5.1.tar.bz2
3a55547e1b6407e7d2faa6e02982ed903c2364381af1b7eeb626ae3a8b0e32558dd79bf31c982b134414e5636d4868c1f3660ac523f25d2440ed6f7b436843bf pdns.initd
3f809f3257680c3e496fa6a4c86c8a636db5d9d5b92aef96fe54c29b8266ee590deb792d13205cc171e27307fa73295dd3b101b09102fd66a2393a7cdbf9dd27 pdns.conf
-a8581c78d0023e57dc98514c53ee63354276e8cb97b38b1d87bd32485d268ad8a8a79151f6a888b03ad65bcb1fa2b532a264e63bdc31e324e803e485e47fec78 pdns-boost-containers-exceptions.patch"
+"
diff --git a/community/pdns/pdns-boost-containers-exceptions.patch b/community/pdns/pdns-boost-containers-exceptions.patch
deleted file mode 100644
index e510f4e1fb5..00000000000
--- a/community/pdns/pdns-boost-containers-exceptions.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-commit db66571e89abf601a711b4a4f3fac19f0ecce342
-Author: Peter van Dijk <peter.van.dijk@powerdns.com>
-Date: Fri Apr 23 14:12:34 2021 +0200
-
- boost 1.76 containers: use standard exceptions
-
- https://www.boost.org/users/history/version_1_76_0.html
-
- > Replaced default standard exception classes with Boost.Container own classes, reducing considerably the included files overhead. Example: in MSVC 19 boost/container/vector.hpp preprocessed file size reduces from 1,5MB to 930KB. If you still want to use standard exception classes, you can define BOOST_CONTAINER_USE_STD_EXCEPTIONS before using any Boost.Container class.
-
-diff --git a/pdns/dnsname.hh b/pdns/dnsname.hh
-index 7f7ee0ad3..c27b6dde7 100644
---- a/pdns/dnsname.hh
-+++ b/pdns/dnsname.hh
-@@ -35,6 +35,7 @@
-
- // it crashes on OSX and doesn't compile on OpenBSD
- #if BOOST_VERSION >= 105300 && ! defined( __APPLE__ ) && ! defined(__OpenBSD__)
-+#define BOOST_CONTAINER_USE_STD_EXCEPTIONS
- #include <boost/container/string.hpp>
- #endif
-
-diff --git a/pdns/dnswriter.cc b/pdns/dnswriter.cc
-index adad9e021..36115dc6d 100644
---- a/pdns/dnswriter.cc
-+++ b/pdns/dnswriter.cc
-@@ -24,6 +24,7 @@
- #endif
- #include <boost/version.hpp>
- #if BOOST_VERSION >= 105400
-+#define BOOST_CONTAINER_USE_STD_EXCEPTIONS
- #include <boost/container/static_vector.hpp>
- #endif
- #include "dnswriter.hh"
-diff --git a/pdns/speedtest.cc b/pdns/speedtest.cc
-index 27205d5ff..6a67bef01 100644
---- a/pdns/speedtest.cc
-+++ b/pdns/speedtest.cc
-@@ -1,5 +1,6 @@
- #include "config.h"
- #include <boost/format.hpp>
-+#define BOOST_CONTAINER_USE_STD_EXCEPTIONS
- #include <boost/container/string.hpp>
- #include "dnsparser.hh"
- #include "sstuff.hh"