aboutsummaryrefslogtreecommitdiffstats
path: root/community/pebble/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/pebble/APKBUILD')
-rw-r--r--community/pebble/APKBUILD36
1 files changed, 21 insertions, 15 deletions
diff --git a/community/pebble/APKBUILD b/community/pebble/APKBUILD
index e0956fa6f66..49e79316c95 100644
--- a/community/pebble/APKBUILD
+++ b/community/pebble/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Duncan Bellamy <dunk@denkimushi.com>
# Maintainer: Duncan Bellamy <dunk@denkimushi.com>
pkgname=pebble
-pkgver=2.3.1
-pkgrel=5
+pkgver=2.5.1
+pkgrel=1
pkgdesc="small RFC 8555 ACME test server not for a production certificate authority"
url="https://github.com/letsencrypt/pebble"
# riscv64 blocked by syscall dependency
@@ -10,25 +10,31 @@ arch="all !riscv64"
license="MPL-2.0"
options="!check net" # no testsuite, needs to download dependencies
makedepends="go"
-source="$pkgname-$pkgver.tar.gz::https://github.com/letsencrypt/pebble/archive/refs/tags/v$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/letsencrypt/pebble/archive/refs/tags/v$pkgver.tar.gz
+ "
+
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
+
+prepare() {
+ default_prepare
+
+ go mod download
+}
build() {
- export GOPATH="$builddir"/build
- cd cmd/pebble
- go install
- cd ../pebble-challtestsrv
- go install
+ go build ./cmd/pebble
+ go build ./cmd/pebble-challtestsrv
}
package() {
- install -Dm 755 "$builddir"/build/bin/pebble \
- "$pkgdir"/usr/bin/pebble
- install -Dm 755 "$builddir"/build/bin/pebble-challtestsrv \
- "$pkgdir"/usr/bin/pebble-challtestsrv
- # allow go pkg to be deleted
- chmod 664 -R build/pkg/.*
+ install -Dm755 \
+ pebble \
+ pebble-challtestsrv \
+ -t "$pkgdir"/usr/bin
}
sha512sums="
-0b7552f195ad8fe2d85dc5688a4bbd858fa83605ae924167fdabb6e298feac92f267031919b17eae900e017b9f17ba4c91f225bb7c7c4640aa59d15449fced14 pebble-2.3.1.tar.gz
+626dccd22be56c0424f5040798bac09586095ce5b2d31c7f5b90a4f6e4dd5e8454046fcbf87303029e4f9f440cb5a0079bc3b36b0f0aa7dfcd15a9103e603a84 pebble-2.5.1.tar.gz
"