aboutsummaryrefslogtreecommitdiffstats
path: root/community/peek/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/peek/APKBUILD')
-rw-r--r--community/peek/APKBUILD32
1 files changed, 23 insertions, 9 deletions
diff --git a/community/peek/APKBUILD b/community/peek/APKBUILD
index 7585a5e7780..18c519fcb72 100644
--- a/community/peek/APKBUILD
+++ b/community/peek/APKBUILD
@@ -1,16 +1,29 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=peek
pkgver=1.5.1
-pkgrel=1
+pkgrel=2
pkgdesc="Simple animated GIF screen recorder with an easy to use interface"
url="https://github.com/phw/peek"
-# mips64 and riscv64 blocked by gst-plugins-bad
-arch="all !mips64 !riscv64"
+arch="all"
license="GPL-3.0-or-later"
-depends="ffmpeg gst-plugins-good gst-plugins-bad"
-makedepends="meson gtk+3.0-dev gettext-dev vala txt2man keybinder3-dev"
-checkdepends="appstream-glib desktop-file-utils"
+depends="
+ ffmpeg
+ gst-plugins-bad
+ gst-plugins-good
+ "
+makedepends="
+ gettext-dev
+ gtk+3.0-dev
+ keybinder3-dev
+ meson
+ txt2man
+ vala
+ "
+checkdepends="
+ appstream-glib
+ desktop-file-utils
+ "
subpackages="$pkgname-lang $pkgname-doc"
source="https://github.com/phw/peek/archive/$pkgver/peek-$pkgver.tar.gz
use-python3.patch
@@ -19,12 +32,13 @@ source="https://github.com/phw/peek/archive/$pkgver/peek-$pkgver.tar.gz
build() {
abuild-meson \
-Denable-filechoosernative=true \
+ -Db_lto=true \
. output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -j ${JOBS:-0} -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {