aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-alien-build-plugin-download-gitlab/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/perl-alien-build-plugin-download-gitlab/APKBUILD')
-rw-r--r--community/perl-alien-build-plugin-download-gitlab/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/community/perl-alien-build-plugin-download-gitlab/APKBUILD b/community/perl-alien-build-plugin-download-gitlab/APKBUILD
new file mode 100644
index 00000000000..b6f1fa8a84a
--- /dev/null
+++ b/community/perl-alien-build-plugin-download-gitlab/APKBUILD
@@ -0,0 +1,37 @@
+# Automatically generated by apkbuild-cpan, template 3
+# Contributor: Timothy Legge <timlegge@gmail.com>
+# Maintainer: Timothy Legge <timlegge@gmail.com>
+pkgname=perl-alien-build-plugin-download-gitlab
+#_pkgreal is used by apkbuild-cpan to find modules at MetaCpan
+_pkgreal=Alien-Build-Plugin-Download-GitLab
+pkgver=0.01
+pkgrel=1
+pkgdesc="Alien::Build plugin to download from GitLab"
+url="https://metacpan.org/release/Alien-Build-Plugin-Download-GitLab/"
+arch="noarch"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
+depends="perl perl-alien-build perl-uri perl-path-tiny perl-uri"
+checkdepends="perl-test2-suite"
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/P/PL/PLICEASE/Alien-Build-Plugin-Download-GitLab-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+build() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make test
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="
+5a1a1dcefbec09732e377c47a961d57cc21a54fef154158dbad1738a93a143348ddc69430b35207d9db111a74592a7120b2abf2f7045818a74a6397bbf07fb06 Alien-Build-Plugin-Download-GitLab-0.01.tar.gz
+"