aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-appconfig/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/perl-appconfig/APKBUILD')
-rw-r--r--community/perl-appconfig/APKBUILD18
1 files changed, 8 insertions, 10 deletions
diff --git a/community/perl-appconfig/APKBUILD b/community/perl-appconfig/APKBUILD
index 6fd206ebafb..57ab547bac7 100644
--- a/community/perl-appconfig/APKBUILD
+++ b/community/perl-appconfig/APKBUILD
@@ -1,31 +1,29 @@
-# Automatically generated by apkbuild-cpan, template 1
+# Automatically generated by apkbuild-cpan, template 3
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=perl-appconfig
+#_pkgreal is used by apkbuild-cpan to find modules at MetaCpan
_pkgreal=AppConfig
pkgver=1.71
-pkgrel=2
+pkgrel=5
pkgdesc="AppConfig is a bundle of Perl5 modules for reading configuration files and parsing command line arguments."
-url="https://metacpan.org/release/AppConfig"
+url="https://metacpan.org/release/AppConfig/"
arch="noarch"
license="GPL-1.0-or-later OR Artistic-1.0-Perl"
depends="perl"
-makedepends="perl-dev"
+checkdepends="perl-test-pod"
subpackages="$pkgname-doc"
source="https://cpan.metacpan.org/authors/id/N/NE/NEILB/AppConfig-$pkgver.tar.gz"
-
builddir="$srcdir/$_pkgreal-$pkgver"
-prepare() {
- default_prepare
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
-}
-
build() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
make
}
check() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
make test
}