aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-business-issn/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/perl-business-issn/APKBUILD')
-rw-r--r--community/perl-business-issn/APKBUILD19
1 files changed, 11 insertions, 8 deletions
diff --git a/community/perl-business-issn/APKBUILD b/community/perl-business-issn/APKBUILD
index 43a03ba2044..e21b0c1f590 100644
--- a/community/perl-business-issn/APKBUILD
+++ b/community/perl-business-issn/APKBUILD
@@ -1,24 +1,26 @@
-# Automatically generated by apkbuild-cpan, template 3
+# Automatically generated by apkbuild-cpan, template 4
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=perl-business-issn
+pkgver=1.006
+pkgrel=0
#_pkgreal is used by apkbuild-cpan to find modules at MetaCpan
_pkgreal=Business-ISSN
-pkgver=1.004
-pkgrel=2
pkgdesc="Perl extension for International Standard Serial Numbers"
url="https://metacpan.org/release/Business-ISSN/"
arch="noarch"
license="Artistic-2.0"
depends="perl"
-makedepends="perl-dev"
subpackages="$pkgname-doc"
-source="https://cpan.metacpan.org/authors/id/B/BD/BDFOY/Business-ISSN-$pkgver.tar.gz"
+source="https://cpan.metacpan.org/authors/id/B/BR/BRIANDFOY/Business-ISSN-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
build() {
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
- PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
+ PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL \
+ INSTALLDIRS=vendor \
+ NO_PACKLIST=1 \
+ NO_PERLLOCAL=1
make
}
@@ -29,7 +31,8 @@ check() {
package() {
make DESTDIR="$pkgdir" install
- find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-sha512sums="5f6223c3f42b483fdcce832f21276a20df1e809f933823caa5115d339eb4e37565d2ec63f3a5bed76a02580cfe81127f150fac5ff323410273d9127b22ad4a5e Business-ISSN-1.004.tar.gz"
+sha512sums="
+ddbdbeb4f30debbf11a3e97d6a44e9a89ada638582d96cf128c54acf5d157700de73de2c8e0977fe2a3ecb4030b8f9d6e8bd141335d7bd59d06c945d643373c7 Business-ISSN-1.006.tar.gz
+"