aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-class-methodmaker/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/perl-class-methodmaker/APKBUILD')
-rw-r--r--community/perl-class-methodmaker/APKBUILD27
1 files changed, 13 insertions, 14 deletions
diff --git a/community/perl-class-methodmaker/APKBUILD b/community/perl-class-methodmaker/APKBUILD
index f0afcfe965f..a5846544956 100644
--- a/community/perl-class-methodmaker/APKBUILD
+++ b/community/perl-class-methodmaker/APKBUILD
@@ -1,34 +1,33 @@
+# Automatically generated by apkbuild-cpan, template 3
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=perl-class-methodmaker
+#_pkgreal is used by apkbuild-cpan to find modules at MetaCpan
+_pkgreal=Class-MethodMaker
pkgver=2.24
-pkgrel=5
-pkgdesc="Create generic class methods"
-url="https://metacpan.org/release/Class-MethodMaker"
+pkgrel=6
+pkgdesc="A module for creating generic methods"
+url="https://metacpan.org/release/Class-MethodMaker/"
arch="all"
-license="GPL"
-depends=""
-depends_dev="perl-dev"
-makedepends="$depends_dev"
-install=""
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
+depends="perl"
+makedepends="perl-dev"
subpackages="$pkgname-doc"
source="https://cpan.metacpan.org/authors/id/S/SC/SCHWIGON/class-methodmaker/Class-MethodMaker-$pkgver.tar.gz"
-
-builddir="$srcdir/Class-MethodMaker-$pkgver"
+builddir="$srcdir/$_pkgreal-$pkgver"
build() {
- cd "$builddir"
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
make
}
check() {
- cd "$builddir"
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
make test
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}