aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-config-simple
diff options
context:
space:
mode:
Diffstat (limited to 'community/perl-config-simple')
-rw-r--r--community/perl-config-simple/APKBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/community/perl-config-simple/APKBUILD b/community/perl-config-simple/APKBUILD
index 8e0afe51456..87d5e915605 100644
--- a/community/perl-config-simple/APKBUILD
+++ b/community/perl-config-simple/APKBUILD
@@ -15,27 +15,27 @@ depends="$cpandepends"
makedepends="perl-dev $cpanmakedepends"
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/S/SH/SHERZODR/$_pkgreal-$pkgver.tar.gz"
-
+
_builddir="$srcdir/$_pkgreal-$pkgver"
-
+
prepare() {
cd "$_builddir"
export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
-
+
build() {
cd "$_builddir"
export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
make && make test
}
-
+
package() {
cd "$_builddir"
make DESTDIR="$pkgdir" install || return 1
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-
+
md5sums="96513b61c7db591339ce2577878a3b32 Config-Simple-4.59.tar.gz"
sha256sums="cb78a975ad8463f992f35f392227aaf188d533c9092373742b3c2bb592781054 Config-Simple-4.59.tar.gz"
sha512sums="23eb4f5ace1288c3d2a6105fa109d08e8170f4c1b5f6a28b460bb9e0fb62c66c7d392712fca0c96d83c4a16f5c940fcbc348d700a7bef86bf2ba37cd114c8a14 Config-Simple-4.59.tar.gz"