aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-data-compare
diff options
context:
space:
mode:
Diffstat (limited to 'community/perl-data-compare')
-rw-r--r--community/perl-data-compare/APKBUILD23
1 files changed, 13 insertions, 10 deletions
diff --git a/community/perl-data-compare/APKBUILD b/community/perl-data-compare/APKBUILD
index 2f5d1596ad0..78808c17f46 100644
--- a/community/perl-data-compare/APKBUILD
+++ b/community/perl-data-compare/APKBUILD
@@ -5,37 +5,40 @@ pkgname=perl-data-compare
_pkgreal=Data-Compare
pkgver=1.25
pkgrel=0
-pkgdesc="unknown"
+pkgdesc="Compare perl data structures"
url="http://search.cpan.org/dist/Data-Compare/"
arch="noarch"
license="GPL PerlArtistic"
cpandepends="perl-file-find-rule"
-cpanmakedepends=" "
+cpanmakedepends=""
depends="$cpandepends"
makedepends="perl-dev $cpanmakedepends"
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/D/DC/DCANTRELL/$_pkgreal-$pkgver.tar.gz"
-_builddir="$srcdir/$_pkgreal-$pkgver"
+builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
- cd "$_builddir"
+ cd "$builddir"
export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
- cd "$_builddir"
+ cd "$builddir"
export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
- make && make test
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-md5sums="6a397ab5833237f3ca05ed7277b19a7a Data-Compare-1.25.tar.gz"
-sha256sums="1d4b36db545fa9fbacd8c012618f6a7846238ee12ab627a2764cfaf45ad4ea73 Data-Compare-1.25.tar.gz"
sha512sums="6db1235672030aa1afe52de1de9fac1f8a2af9eed99a3143d6c5b30669908125f584638fe06b8b33208f6d7fb734ccec7381c9411408a3f4fde1998707f748c9 Data-Compare-1.25.tar.gz"