aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-date-manip/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/perl-date-manip/APKBUILD')
-rw-r--r--community/perl-date-manip/APKBUILD23
1 files changed, 17 insertions, 6 deletions
diff --git a/community/perl-date-manip/APKBUILD b/community/perl-date-manip/APKBUILD
index 96b3f82096d..debddb2d495 100644
--- a/community/perl-date-manip/APKBUILD
+++ b/community/perl-date-manip/APKBUILD
@@ -1,10 +1,10 @@
-# Automatically generated by apkbuild-cpan, template 3
+# Automatically generated by apkbuild-cpan, template 4
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=perl-date-manip
+pkgver=6.95
+pkgrel=0
#_pkgreal is used by apkbuild-cpan to find modules at MetaCpan
_pkgreal=Date-Manip
-pkgver=6.85
-pkgrel=0
pkgdesc="Date manipulation routines"
url="https://metacpan.org/release/Date-Manip/"
arch="noarch"
@@ -17,7 +17,10 @@ builddir="$srcdir/$_pkgreal-$pkgver"
build() {
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
- PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
+ PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL \
+ INSTALLDIRS=vendor \
+ NO_PACKLIST=1 \
+ NO_PERLLOCAL=1
make
}
@@ -28,7 +31,15 @@ check() {
package() {
make DESTDIR="$pkgdir" install
- find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-sha512sums="ac2fd3823d4890677c9231417bd9838c830d16564ba3f5de04f827d30baddb3fc95a7c379c42d00a3f08e60aba0af8b8f5d710f587d4c5908447a707d1104162 Date-Manip-6.85.tar.gz"
+doc() {
+ local file; find "$pkgdir" -name "*.pod" | while read -r file; do
+ amove "${file#"$pkgdir"}"
+ done
+ default_doc
+}
+
+sha512sums="
+08cefda5b9795484e7fbd7ebecc4094be6ad1fbdc53a6d295b52118a1114338ee36ba0bffccc9ddba40583884a50b5dd46fd2a701259783c812a70ec8dd2ea81 Date-Manip-6.95.tar.gz
+"