aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-date-manip/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/perl-date-manip/APKBUILD')
-rw-r--r--community/perl-date-manip/APKBUILD24
1 files changed, 17 insertions, 7 deletions
diff --git a/community/perl-date-manip/APKBUILD b/community/perl-date-manip/APKBUILD
index 74a037e524a..debddb2d495 100644
--- a/community/perl-date-manip/APKBUILD
+++ b/community/perl-date-manip/APKBUILD
@@ -1,16 +1,15 @@
-# Automatically generated by apkbuild-cpan, template 3
+# Automatically generated by apkbuild-cpan, template 4
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=perl-date-manip
+pkgver=6.95
+pkgrel=0
#_pkgreal is used by apkbuild-cpan to find modules at MetaCpan
_pkgreal=Date-Manip
-pkgver=6.83
-pkgrel=0
pkgdesc="Date manipulation routines"
url="https://metacpan.org/release/Date-Manip/"
arch="noarch"
license="GPL-1.0-or-later OR Artistic-1.0-Perl"
depends="perl"
-makedepends="perl-dev"
checkdepends="perl-test-inter"
subpackages="$pkgname-doc"
source="https://cpan.metacpan.org/authors/id/S/SB/SBECK/Date-Manip-$pkgver.tar.gz"
@@ -18,7 +17,10 @@ builddir="$srcdir/$_pkgreal-$pkgver"
build() {
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
- PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
+ PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL \
+ INSTALLDIRS=vendor \
+ NO_PACKLIST=1 \
+ NO_PERLLOCAL=1
make
}
@@ -29,7 +31,15 @@ check() {
package() {
make DESTDIR="$pkgdir" install
- find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-sha512sums="67983bdd0eb26ef06fa1b908f8b4f7832882442afaff94da009f149e66128df18dc36fba8ba4d72071a76eb3f080e6991e0854cb965e8f5ec4a4525f79e64d39 Date-Manip-6.83.tar.gz"
+doc() {
+ local file; find "$pkgdir" -name "*.pod" | while read -r file; do
+ amove "${file#"$pkgdir"}"
+ done
+ default_doc
+}
+
+sha512sums="
+08cefda5b9795484e7fbd7ebecc4094be6ad1fbdc53a6d295b52118a1114338ee36ba0bffccc9ddba40583884a50b5dd46fd2a701259783c812a70ec8dd2ea81 Date-Manip-6.95.tar.gz
+"