aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-datetime-format-iso8601/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/perl-datetime-format-iso8601/APKBUILD')
-rw-r--r--community/perl-datetime-format-iso8601/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/community/perl-datetime-format-iso8601/APKBUILD b/community/perl-datetime-format-iso8601/APKBUILD
new file mode 100644
index 00000000000..37b79060c2e
--- /dev/null
+++ b/community/perl-datetime-format-iso8601/APKBUILD
@@ -0,0 +1,38 @@
+# Automatically generated by apkbuild-cpan, template 3
+# Contributor: Timothy Legge <timlegge@gmail.com>
+# Maintainer: Timothy Legge <timlegge@gmail.com>
+pkgname=perl-datetime-format-iso8601
+#_pkgreal is used by apkbuild-cpan to find modules at MetaCpan
+_pkgreal=DateTime-Format-ISO8601
+pkgver=0.16
+pkgrel=1
+pkgdesc="Parses ISO8601 formats"
+url="https://metacpan.org/release/DateTime-Format-ISO8601/"
+arch="noarch"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
+depends="
+ perl perl-datetime perl-datetime-format-builder perl-specio perl-namespace-autoclean
+ perl-params-validationcompiler
+ "
+checkdepends="perl-test2-suite"
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/D/DR/DROLSKY/DateTime-Format-ISO8601-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+build() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make test
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="3a8985d06f3953308cb9ebb8f322b5cbf6c3dfba99a71a4e2005ba5b23d9b2f2d3967f76e2d09991b75833dc70a4aa352829648b601e79054da79304904a07e4 DateTime-Format-ISO8601-0.16.tar.gz"