aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-datetime-format-xsd/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/perl-datetime-format-xsd/APKBUILD')
-rw-r--r--community/perl-datetime-format-xsd/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/community/perl-datetime-format-xsd/APKBUILD b/community/perl-datetime-format-xsd/APKBUILD
new file mode 100644
index 00000000000..15900ecdf57
--- /dev/null
+++ b/community/perl-datetime-format-xsd/APKBUILD
@@ -0,0 +1,34 @@
+# Automatically generated by apkbuild-cpan, template 3
+# Contributor: Timothy Legge <timlegge@gmail.com>
+# Maintainer: Timothy Legge <timlegge@gmail.com>
+pkgname=perl-datetime-format-xsd
+#_pkgreal is used by apkbuild-cpan to find modules at MetaCpan
+_pkgreal=DateTime-Format-XSD
+pkgver=0.4
+pkgrel=1
+pkgdesc="Format DateTime according to xsd:dateTime"
+url="https://metacpan.org/release/DateTime-Format-XSD/"
+arch="noarch"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
+depends="perl perl-datetime-format-iso8601"
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/T/TI/TIMLEGGE/DateTime-Format-XSD-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+build() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make test
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="1404971b7b82daf64fa2d3b397cb1da84f12448f893586b5e7352273e80be7e1a0ef04faf5b531cfd71843a8abbf9f76cd2fd47f18e9f0850cc3b1f7f523e0ea DateTime-Format-XSD-0.4.tar.gz"