aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-email-mime-contenttype/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/perl-email-mime-contenttype/APKBUILD')
-rw-r--r--community/perl-email-mime-contenttype/APKBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/community/perl-email-mime-contenttype/APKBUILD b/community/perl-email-mime-contenttype/APKBUILD
index 82eec0db74d..85b745f6b29 100644
--- a/community/perl-email-mime-contenttype/APKBUILD
+++ b/community/perl-email-mime-contenttype/APKBUILD
@@ -15,23 +15,27 @@ depends="$cpandepends"
makedepends="perl-dev $cpanmakedepends"
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/R/RJ/RJBS/$_pkgreal-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
-_builddir="$srcdir/$_pkgreal-$pkgver"
+check() {
+ cd "$builddir"
+ make test
+}
prepare() {
- cd "$_builddir"
+ cd "$builddir"
export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
- cd "$_builddir"
+ cd "$builddir"
export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
- make && make test
+ make
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make DESTDIR="$pkgdir" install || return 1
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}