aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-email-simple/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/perl-email-simple/APKBUILD')
-rw-r--r--community/perl-email-simple/APKBUILD23
1 files changed, 15 insertions, 8 deletions
diff --git a/community/perl-email-simple/APKBUILD b/community/perl-email-simple/APKBUILD
index e9779c2d46e..8d9b4646bb8 100644
--- a/community/perl-email-simple/APKBUILD
+++ b/community/perl-email-simple/APKBUILD
@@ -4,35 +4,42 @@
pkgname=perl-email-simple
_pkgreal=Email-Simple
pkgver=2.214
-pkgrel=0
+pkgrel=1
pkgdesc="unknown"
url="http://search.cpan.org/dist/Email-Simple/"
arch="noarch"
license="GPL PerlArtistic"
cpandepends="perl-email-date-format"
-cpanmakedepends=" "
+cpanmakedepends=""
depends="$cpandepends"
makedepends="perl-dev $cpanmakedepends"
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/R/RJ/RJBS/$_pkgreal-$pkgver.tar.gz"
-_builddir="$srcdir/$_pkgreal-$pkgver"
+builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
- cd "$_builddir"
+ default_prepare
+
+ cd "$builddir"
export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
- cd "$_builddir"
+ cd "$builddir"
export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
- make && make test
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}