aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-graph/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/perl-graph/APKBUILD')
-rw-r--r--community/perl-graph/APKBUILD41
1 files changed, 16 insertions, 25 deletions
diff --git a/community/perl-graph/APKBUILD b/community/perl-graph/APKBUILD
index f32fbbe4f20..8d13be94c2a 100644
--- a/community/perl-graph/APKBUILD
+++ b/community/perl-graph/APKBUILD
@@ -1,46 +1,37 @@
-# Automatically generated by apkbuild-cpan, template 1
+# Automatically generated by apkbuild-cpan, template 3
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=perl-graph
+#_pkgreal is used by apkbuild-cpan to find modules at MetaCpan
_pkgreal=Graph
-pkgver=0.9704
-pkgrel=2
-pkgdesc="Graph data structures and algorithms"
-url="http://search.cpan.org/dist/Graph/"
+pkgver=0.9727
+pkgrel=1
+pkgdesc="Perl module for Graph"
+url="https://metacpan.org/release/Graph/"
arch="noarch"
-license="GPL PerlArtistic"
-cpandepends=""
-cpanmakedepends=""
-depends="$cpandepends"
-makedepends="perl-dev $cpanmakedepends"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
+depends="perl perl-heap"
+checkdepends="perl-set-object"
subpackages="$pkgname-doc"
-source="http://search.cpan.org/CPAN/authors/id/J/JH/JHI/$_pkgreal-$pkgver.tar.gz"
-
+source="https://cpan.metacpan.org/authors/id/E/ET/ETJ/Graph-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
-prepare() {
- default_prepare
-
- cd "$builddir"
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
-}
-
build() {
- cd "$builddir"
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
make
}
check() {
- cd "$builddir"
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
make test
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-sha512sums="1eed5049577112cc2e41a83f6b3b6a22a08170597b5cb89e2eab6cc68386bfd989d3953d7ceab85bcfbd7d097a6925bd8eb43f48eed1ac07469ea4b2432149da Graph-0.9704.tar.gz"
+sha512sums="
+e5274aa86f0c0fab6acff29af1253accb4159785fa6c32edefd080bc2b840c959c1a18e2f6db193fda469871294ec02b4d726f73c4b0076fe97b4c61cccd2c3e Graph-0.9727.tar.gz
+"