aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-hash-mostutils/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/perl-hash-mostutils/APKBUILD')
-rw-r--r--community/perl-hash-mostutils/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/community/perl-hash-mostutils/APKBUILD b/community/perl-hash-mostutils/APKBUILD
new file mode 100644
index 00000000000..ef8d3e72e60
--- /dev/null
+++ b/community/perl-hash-mostutils/APKBUILD
@@ -0,0 +1,40 @@
+# Automatically generated by apkbuild-cpan, template 1
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=perl-hash-mostutils
+_pkgreal=Hash-MostUtils
+pkgver=1.07
+pkgrel=0
+pkgdesc="Pairwise list manipulators"
+url="http://search.cpan.org/dist/Hash-MostUtils/"
+arch="noarch"
+license="GPL PerlArtistic"
+cpandepends="perl-provide"
+cpanmakedepends=" "
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/B/BE/BELDEN/$_pkgreal-$pkgver.tar.gz"
+
+_builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+}
+
+build() {
+ cd "$_builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ make && make test
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="854d195478d801b9e9a4fe68be06d2cd Hash-MostUtils-1.07.tar.gz"
+sha256sums="3d165b7336d56813316fe38625dab450ae23a86149e191589148fce7899a1b48 Hash-MostUtils-1.07.tar.gz"
+sha512sums="63f0b38a76eac53097c47ea0f998c5b1ddfc8e0888bf9e62ad0c944ee22aca7eca1eaeba07ef284a318f4a03e29bf7bb52b521be994c979352e792ec02ae2eca Hash-MostUtils-1.07.tar.gz"