aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-http-parser-xs/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/perl-http-parser-xs/APKBUILD')
-rw-r--r--community/perl-http-parser-xs/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/community/perl-http-parser-xs/APKBUILD b/community/perl-http-parser-xs/APKBUILD
new file mode 100644
index 00000000000..0b9a91df1e0
--- /dev/null
+++ b/community/perl-http-parser-xs/APKBUILD
@@ -0,0 +1,35 @@
+# Automatically generated by apkbuild-cpan, template 3
+# Contributor: Timo Teräs <timo.teras@iki.fi>
+# Maintainer: Timo Teräs <timo.teras@iki.fi>
+pkgname=perl-http-parser-xs
+#_pkgreal is used by apkbuild-cpan to find modules at MetaCpan
+_pkgreal=HTTP-Parser-XS
+pkgver=0.17
+pkgrel=7
+pkgdesc="a fast, primitive HTTP request parser"
+url="https://metacpan.org/release/HTTP-Parser-XS/"
+arch="all"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
+depends="perl"
+makedepends="perl-dev"
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/K/KA/KAZUHO/HTTP-Parser-XS-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+build() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make test
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="44375b93e8aea04bedee283b1796eb6e94a2920be7ae29fe2f7d83491005b4d8f29047ddf52c6d7f62cf5a9f2575d7f6ea7d357e178536f60dd2c3cee08f495e HTTP-Parser-XS-0.17.tar.gz"