aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-io-string/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/perl-io-string/APKBUILD')
-rw-r--r--community/perl-io-string/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/community/perl-io-string/APKBUILD b/community/perl-io-string/APKBUILD
new file mode 100644
index 00000000000..913c4245cbe
--- /dev/null
+++ b/community/perl-io-string/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Milan P. Stanić <mps@arvanta.net>
+# Maintainer: Milan P. Stanić <mps@arvanta.net>
+pkgname=perl-io-string
+_pkgreal=IO-String
+pkgver=1.08
+pkgrel=3
+pkgdesc="emulate file interface for in-core strings "
+url="https://metacpan.org/release/IO-String"
+arch="noarch"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
+depends="perl"
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/G/GA/GAAS/$_pkgreal-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ default_prepare
+
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
+}
+
+build() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+check() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make test
+}
+
+sha512sums="0aae1711a2bad2a239d90ca7ceb685938e509dbefb05d6c6717796a04ce1956006f67a7a203eaa9d9718b77b5cea9b7d493091b88d9542068f0829aae3a37376 IO-String-1.08.tar.gz"