aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-iptables-parse
diff options
context:
space:
mode:
Diffstat (limited to 'community/perl-iptables-parse')
-rw-r--r--community/perl-iptables-parse/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/community/perl-iptables-parse/APKBUILD b/community/perl-iptables-parse/APKBUILD
new file mode 100644
index 00000000000..97aa093abe1
--- /dev/null
+++ b/community/perl-iptables-parse/APKBUILD
@@ -0,0 +1,41 @@
+# Automatically generated by apkbuild-cpan, template 1
+# Contributor: Stuart Cardall <developer@it-offshore.co.uk>
+# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
+pkgname=perl-iptables-parse
+_pkgreal=IPTables-Parse
+pkgver=1.6.1
+pkgrel=0
+pkgdesc="Perl extension for parsing iptables and ip6tables firewall rulesets"
+url="http://search.cpan.org/dist/IPTables-Parse/"
+arch="noarch"
+license="artistic_1"
+cpandepends=""
+cpanmakedepends=""
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/M/MR/MRASH/$_pkgreal-$pkgver.tar.gz"
+
+_builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+}
+
+build() {
+ cd "$_builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ make && make test
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="72299f0ab6e10a51837a48d51728a6f7 IPTables-Parse-1.6.1.tar.gz"
+sha256sums="b04a2fe8b021673f2035ac94784bb1c5353a0fd936ab8f093ad23af2b33106e4 IPTables-Parse-1.6.1.tar.gz"
+sha512sums="7638665e34f06771519bc8989ad57b6308c5efb39ecb32f3f6f208d0ece1675f499452f4b4b5b2ddd25109abecbdb5015e4441431defa8688f33f9eb2ad921eb IPTables-Parse-1.6.1.tar.gz"