aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-locale-codes/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/perl-locale-codes/APKBUILD')
-rw-r--r--community/perl-locale-codes/APKBUILD21
1 files changed, 15 insertions, 6 deletions
diff --git a/community/perl-locale-codes/APKBUILD b/community/perl-locale-codes/APKBUILD
index d45c04ab02b..f15ee88194b 100644
--- a/community/perl-locale-codes/APKBUILD
+++ b/community/perl-locale-codes/APKBUILD
@@ -1,11 +1,11 @@
-# Automatically generated by apkbuild-cpan, template 3
+# Automatically generated by apkbuild-cpan, template 4
# Contributor: Timothy Legge <timlegge@gmail.com>
# Maintainer: Timothy Legge <timlegge@gmail.com>
pkgname=perl-locale-codes
+pkgver=3.78
+pkgrel=0
#_pkgreal is used by apkbuild-cpan to find modules at MetaCpan
_pkgreal=Locale-Codes
-pkgver=3.71
-pkgrel=0
pkgdesc="a distribution of modules to handle locale codes"
url="https://metacpan.org/release/Locale-Codes/"
arch="noarch"
@@ -18,7 +18,10 @@ builddir="$srcdir/$_pkgreal-$pkgver"
build() {
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
- PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
+ PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL \
+ INSTALLDIRS=vendor \
+ NO_PACKLIST=1 \
+ NO_PERLLOCAL=1
make
}
@@ -29,9 +32,15 @@ check() {
package() {
make DESTDIR="$pkgdir" install
- find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+doc() {
+ local file; find "$pkgdir" -name "*.pod" | while read -r file; do
+ amove "${file#"$pkgdir"}"
+ done
+ default_doc
}
sha512sums="
-04f3c4d2e27acccbef1627125d5a48b41fbbb9e9c13abf75adb9d90716bda390218f10b68b19edb461f723c600c37501b413006480cda1ac969906cc07d39eda Locale-Codes-3.71.tar.gz
+640241a896ab20747360766cc98f69f953559d225113135ae2131656381526e8639c3ac6a03c4f41d373b8a330a26e0c3ded7ba65b163d4eefc1c2119180a22c Locale-Codes-3.78.tar.gz
"