aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-math-pari/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/perl-math-pari/APKBUILD')
-rw-r--r--community/perl-math-pari/APKBUILD19
1 files changed, 12 insertions, 7 deletions
diff --git a/community/perl-math-pari/APKBUILD b/community/perl-math-pari/APKBUILD
index 7a48cde34bc..aded17e43a4 100644
--- a/community/perl-math-pari/APKBUILD
+++ b/community/perl-math-pari/APKBUILD
@@ -1,23 +1,26 @@
-# Automatically generated by apkbuild-cpan, template 2
+# Automatically generated by apkbuild-cpan, template 3
# Contributor: Timothy Legge <timlegge@gmail.com>
# Maintainer: Timothy Legge <timlegge@gmail.com>
pkgname=perl-math-pari
+#_pkgreal is used by apkbuild-cpan to find modules at MetaCpan
_pkgreal=Math-Pari
-pkgver=2.030518
-pkgrel=2
+pkgver=2.030523
+pkgrel=1
pkgdesc="Perl interface to PARI."
url="https://metacpan.org/release/Math-Pari/"
arch="all !s390x" #Tests do not work on S390
-license="GPL-2.0-or-later OR Artistic-1.0-Perl"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl OR GPL-2.0-only"
+depends="perl"
makedepends="perl-dev"
+options="net" # additional sources downloaded from FTP
subpackages="$pkgname-doc"
-source="https://cpan.metacpan.org/authors/id/I/IL/ILYAZ/modules/Math-Pari-$pkgver.zip"
+source="https://cpan.metacpan.org/authors/id/I/IL/ILYAZ/modules/Math-Pari-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
build() {
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
- make
+ make -j1
}
check() {
@@ -30,4 +33,6 @@ package() {
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-sha512sums="9bb5d789b5789b38c1d2f07b400f394f8b94872321e9b4de8177e0546fde5f13c277a268f707fbd4c35b336d5f1f86c62744e8a8d0a7d54acece89f1125a89a2 Math-Pari-2.030518.zip"
+sha512sums="
+4f75a745111eed1c326270fc4cff5f7785fd353ffbbaf21a33215974671cdb2a4ff8d397a2df41b24002312a43993114a3620f5b6ed7eb6d4bdae9c4f62d671c Math-Pari-2.030523.tar.gz
+"