aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-math-random-mt-auto/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/perl-math-random-mt-auto/APKBUILD')
-rw-r--r--community/perl-math-random-mt-auto/APKBUILD19
1 files changed, 7 insertions, 12 deletions
diff --git a/community/perl-math-random-mt-auto/APKBUILD b/community/perl-math-random-mt-auto/APKBUILD
index a67a9c59669..bc85568adce 100644
--- a/community/perl-math-random-mt-auto/APKBUILD
+++ b/community/perl-math-random-mt-auto/APKBUILD
@@ -1,39 +1,34 @@
# Automatically generated by apkbuild-cpan, template 1
-# Contributor: Kiyoshi Aman <kiyoshi.aman@gmail.com>
-# Maintainer: Kiyoshi Aman <kiyoshi.aman@gmail.com>
+# Contributor: Sheila Aman <sheila@vulpine.house>
+# Maintainer: Sheila Aman <sheila@vulpine.house>
pkgname=perl-math-random-mt-auto
_pkgreal=Math-Random-MT-Auto
pkgver=6.23
-pkgrel=4
+pkgrel=8
pkgdesc="Auto-seeded Mersenne Twister PRNGs"
url="https://metacpan.org/release/Math-Random-MT-Auto/"
arch="all"
-license="unrestricted"
-cpandepends="perl-exception-class perl-object-insideout"
-depends="$cpandepends"
+license="BSD-3-Clause"
+depends="perl-exception-class perl-object-insideout"
makedepends="perl-dev"
subpackages="$pkgname-doc"
source="https://cpan.metacpan.org/authors/id/J/JD/JDHEDDEN/$_pkgreal-$pkgver.tar.gz"
-
-builddir="$srcdir/$_pkgreal-$pkgver"
+builddir="$srcdir"/$_pkgreal-$pkgver
prepare() {
- cd "$builddir"
+ default_prepare
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
- cd "$builddir"
make
}
check() {
- cd "$builddir"
make test
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}