aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-module-build-xsutil/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/perl-module-build-xsutil/APKBUILD')
-rw-r--r--community/perl-module-build-xsutil/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/community/perl-module-build-xsutil/APKBUILD b/community/perl-module-build-xsutil/APKBUILD
new file mode 100644
index 00000000000..9811ce80220
--- /dev/null
+++ b/community/perl-module-build-xsutil/APKBUILD
@@ -0,0 +1,35 @@
+# Automatically generated by apkbuild-cpan, template 3
+# Contributor: Timothy Legge <timlegge@gmail.com>
+# Maintainer: Timothy Legge <timlegge@gmail.com>
+pkgname=perl-module-build-xsutil
+#_pkgreal is used by apkbuild-cpan to find modules at MetaCpan
+_pkgreal=Module-Build-XSUtil
+pkgver=0.19
+pkgrel=1
+pkgdesc="A Module::Build class for building XS modules"
+url="https://metacpan.org/release/Module-Build-XSUtil/"
+arch="noarch"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
+depends="perl perl-devel-checkcompiler"
+makedepends="perl-dev perl-module-build perl-module-build"
+checkdepends="perl-capture-tiny perl-file-copy-recursive-reduced perl-cwd-guard"
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/H/HI/HIDEAKIO/Module-Build-XSUtil-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+build() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ perl Build.PL --installdirs=vendor
+ ./Build
+}
+
+check() {
+ ./Build test
+}
+
+package() {
+ ./Build install --destdir="$pkgdir"
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="187f504c3f26d15b96cdc5b682d3487a31cf124475160b7fe5dce727d5d6ec5de5a58d09535adb62a1a95b3030fb62951b2cc0eca860eb03c66a48042cea8819 Module-Build-XSUtil-0.19.tar.gz"