aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-net-appliance-session/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/perl-net-appliance-session/APKBUILD')
-rw-r--r--community/perl-net-appliance-session/APKBUILD16
1 files changed, 6 insertions, 10 deletions
diff --git a/community/perl-net-appliance-session/APKBUILD b/community/perl-net-appliance-session/APKBUILD
index e2185f2f062..28bec12c46f 100644
--- a/community/perl-net-appliance-session/APKBUILD
+++ b/community/perl-net-appliance-session/APKBUILD
@@ -4,9 +4,9 @@
pkgname=perl-net-appliance-session
_pkgreal=Net-Appliance-Session
pkgver=4.300005
-pkgrel=0
+pkgrel=4
pkgdesc="Run command-line sessions to network appliances"
-url="http://search.cpan.org/dist/Net-Appliance-Session/"
+url="https://metacpan.org/release/Net-Appliance-Session/"
arch="noarch"
license="GPL PerlArtistic"
cpandepends="perl-moose perl-net-cli-interact perl-file-sharedir perl-text-glob
@@ -15,29 +15,25 @@ cpanmakedepends="perl-module-build perl-namespace-autoclean perl-specio perl-par
depends="$cpandepends"
makedepends="perl-dev $cpanmakedepends"
subpackages="$pkgname-doc"
-source="http://search.cpan.org/CPAN/authors/id/O/OL/OLIVER/$_pkgreal-$pkgver.tar.gz"
+source="https://cpan.metacpan.org/authors/id/O/OL/OLIVER/$_pkgreal-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
- cd "$builddir"
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
perl Build.PL installdirs=vendor
}
build() {
- cd "$builddir"
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
./Build
}
check() {
- cd "$builddir"
./Build test
}
package() {
- cd "$builddir"
- ./Build install destdir="$pkgdir" || return 1
+ ./Build install destdir="$pkgdir"
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}