aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-net-iptrie/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/perl-net-iptrie/APKBUILD')
-rw-r--r--community/perl-net-iptrie/APKBUILD18
1 files changed, 5 insertions, 13 deletions
diff --git a/community/perl-net-iptrie/APKBUILD b/community/perl-net-iptrie/APKBUILD
index b7fc0e09fd6..958d29173df 100644
--- a/community/perl-net-iptrie/APKBUILD
+++ b/community/perl-net-iptrie/APKBUILD
@@ -4,15 +4,12 @@
pkgname=perl-net-iptrie
_pkgreal=Net-IPTrie
pkgver=0.7
-pkgrel=4
+pkgrel=5
pkgdesc="Perl module for building IPv4 and IPv6 address space hierarchies"
url="https://metacpan.org/release/Net-IPTrie/"
arch="noarch"
-license="GPL PerlArtistic"
-cpandepends="perl-netaddr-ip perl-module-build"
-cpanmakedepends=""
-depends="$cpandepends"
-makedepends="perl-dev $cpanmakedepends"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
+depends="perl perl-netaddr-ip perl-module-build"
subpackages="$pkgname-doc"
source="https://cpan.metacpan.org/authors/id/C/CV/CVICENTE/$_pkgreal-$pkgver.tar.gz"
@@ -20,24 +17,19 @@ builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
default_prepare
-
- cd "$builddir"
perl Build.PL installdirs=vendor
}
build() {
- cd "$builddir"
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
./Build
}
check() {
- cd "$builddir"
- ./Build test
+ ./Build test
}
package() {
- cd "$builddir"
./Build install destdir="$pkgdir"
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}