aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-rt-extension-commandbymail/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/perl-rt-extension-commandbymail/APKBUILD')
-rw-r--r--community/perl-rt-extension-commandbymail/APKBUILD42
1 files changed, 18 insertions, 24 deletions
diff --git a/community/perl-rt-extension-commandbymail/APKBUILD b/community/perl-rt-extension-commandbymail/APKBUILD
index 2d31632097d..c2818925890 100644
--- a/community/perl-rt-extension-commandbymail/APKBUILD
+++ b/community/perl-rt-extension-commandbymail/APKBUILD
@@ -1,41 +1,35 @@
-# Automatically generated by apkbuild-cpan, template 1
-# Extensively modified from template to work with this perl module
+# Automatically generated by apkbuild-cpan, template 3
# Contributor: Timo Teräs <timo.teras@iki.fi>
# Maintainer: Timo Teräs <timo.teras@iki.fi>
pkgname=perl-rt-extension-commandbymail
+#_pkgreal is used by apkbuild-cpan to find modules at MetaCpan
_pkgreal=RT-Extension-CommandByMail
-pkgver=3.00
-pkgrel=2
+pkgver=3.01
+pkgrel=1
pkgdesc="RT4 extension to change metadata of a ticket via email"
url="https://metacpan.org/release/RT-Extension-CommandByMail/"
arch="noarch"
-license="GPL PerlArtistic"
-cpandepends="perl-mime-tools perl-universal-require"
-cpanmakedepends=" "
-depends="$cpandepends"
-makedepends="rt4 perl-dev $cpanmakedepends"
+license="GPL-2.0-only"
+depends="perl"
+makedepends="rt4"
subpackages="$pkgname-doc"
-source="https://cpan.metacpan.org/authors/id/B/BP/BPS/RT-Extension-CommandByMail-$pkgver.tar.gz
- fix-build.patch"
-
-# Running tests would require RT4 database to be available
-options="!check"
-
+source="https://cpan.metacpan.org/authors/id/B/BP/BPS/RT-Extension-CommandByMail-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
build() {
- cd "$builddir"
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
make
}
+check() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make test
+}
+
package() {
- cd "$builddir"
- make PERL_INSTALL_ROOT="$pkgdir" pure_install
- find "$pkgdir" \( -name perllocal.pod -o -name .packlist -o -name Test.pm \) -delete
- find "$pkgdir" -type d -delete 2> /dev/null
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-sha512sums="91ea0bd9f9aa32ee09635a910c5d082032bcd94170e22854833c1aa6aacdc68d54687d32cbc92b5e298e62812d23d2fe81e30acd55d11d6d2e910e210be8930c RT-Extension-CommandByMail-3.00.tar.gz
-75fd4f293da4beff01b7cc6511d040b350791e425736104cc9d382e6f172acf66cdbbbf5c02d500e70b3df773ad02af25a78a66c21c70079a7bc5ecc11e1812c fix-build.patch"
+sha512sums="a3b3104d589cf00e1aa05ef174dbaecbe182f1729db06ef91f850d9b552df5722b36bc929a373d4b055d0d693a24e6c2f4aafcd1f8bdaef8a3873556e61be753 RT-Extension-CommandByMail-3.01.tar.gz"