aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-rt-extension-commandbymail/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/perl-rt-extension-commandbymail/APKBUILD')
-rw-r--r--community/perl-rt-extension-commandbymail/APKBUILD33
1 files changed, 14 insertions, 19 deletions
diff --git a/community/perl-rt-extension-commandbymail/APKBUILD b/community/perl-rt-extension-commandbymail/APKBUILD
index 679c9181a4f..cb1229fc9d6 100644
--- a/community/perl-rt-extension-commandbymail/APKBUILD
+++ b/community/perl-rt-extension-commandbymail/APKBUILD
@@ -1,40 +1,35 @@
-# Automatically generated by apkbuild-cpan, template 1
-# Extensively modified from template to work with this perl module
+# Automatically generated by apkbuild-cpan, template 3
# Contributor: Timo Teräs <timo.teras@iki.fi>
# Maintainer: Timo Teräs <timo.teras@iki.fi>
pkgname=perl-rt-extension-commandbymail
+#_pkgreal is used by apkbuild-cpan to find modules at MetaCpan
_pkgreal=RT-Extension-CommandByMail
pkgver=3.01
pkgrel=0
pkgdesc="RT4 extension to change metadata of a ticket via email"
url="https://metacpan.org/release/RT-Extension-CommandByMail/"
arch="noarch"
-license="GPL PerlArtistic"
-cpandepends="perl-mime-tools perl-universal-require"
-cpanmakedepends=" "
-depends="$cpandepends"
-makedepends="rt4 perl-dev $cpanmakedepends"
+license="GPL-2.0-only"
+depends="perl"
+makedepends="perl-dev rt4"
subpackages="$pkgname-doc"
source="https://cpan.metacpan.org/authors/id/B/BP/BPS/RT-Extension-CommandByMail-$pkgver.tar.gz"
-
-# Running tests would require RT4 database to be available
-options="!check"
-
builddir="$srcdir/$_pkgreal-$pkgver"
build() {
- cd "$builddir"
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
make
}
-package() {
- cd "$builddir"
- make PERL_INSTALL_ROOT="$pkgdir" pure_install
- find "$pkgdir" \( -name perllocal.pod -o -name .packlist -o -name Test.pm \) -delete
- find "$pkgdir" -type d -delete 2> /dev/null
+check() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make test
}
+package() {
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
sha512sums="a3b3104d589cf00e1aa05ef174dbaecbe182f1729db06ef91f850d9b552df5722b36bc929a373d4b055d0d693a24e6c2f4aafcd1f8bdaef8a3873556e61be753 RT-Extension-CommandByMail-3.01.tar.gz"