aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-spiffy/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/perl-spiffy/APKBUILD')
-rw-r--r--community/perl-spiffy/APKBUILD18
1 files changed, 5 insertions, 13 deletions
diff --git a/community/perl-spiffy/APKBUILD b/community/perl-spiffy/APKBUILD
index 924b62aa0b3..9a523de1316 100644
--- a/community/perl-spiffy/APKBUILD
+++ b/community/perl-spiffy/APKBUILD
@@ -4,41 +4,33 @@
pkgname=perl-spiffy
_pkgreal=Spiffy
pkgver=0.46
-pkgrel=3
+pkgrel=4
pkgdesc="Spiffy Perl Interface Framework For You"
url="https://metacpan.org/release/Spiffy/"
arch="noarch"
-license="GPL PerlArtistic"
-cpandepends=""
-cpanmakedepends=" "
-depends="$cpandepends"
-makedepends="perl-dev $cpanmakedepends"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
+depends="perl"
subpackages="$pkgname-doc"
source="https://cpan.metacpan.org/authors/id/I/IN/INGY/$_pkgreal-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
default_prepare
-
- cd "$builddir"
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
- cd "$builddir"
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
make
}
check() {
- cd "$builddir"
- make test
+ make test
}
package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}