aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-test-command
diff options
context:
space:
mode:
Diffstat (limited to 'community/perl-test-command')
-rw-r--r--community/perl-test-command/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/community/perl-test-command/APKBUILD b/community/perl-test-command/APKBUILD
new file mode 100644
index 00000000000..a921607f2ec
--- /dev/null
+++ b/community/perl-test-command/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Maintainer: Celeste <cielesti@protonmail.com>
+pkgname=perl-test-command
+#_pkgreal is used by apkbuild-cpan to find modules at MetaCpan
+_pkgreal=Test-Command
+pkgver=0.11
+pkgrel=2
+pkgdesc="Perl module for testing external commands"
+url="https://metacpan.org/release/Test-Command"
+arch="noarch"
+license="Artistic-1.0-Perl OR GPL-1.0-or-later"
+depends="perl"
+checkdepends="perl-pod-coverage perl-test-pod-coverage"
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/D/DA/DANBOO/Test-Command-$pkgver.tar.gz"
+builddir="$srcdir/Test-Command-$pkgver"
+
+build() {
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ make test
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="
+79a8f41132b965ad4f6e8b4d97f8fb6181a1e394bcf8825abda2c8ee12dd5f6ef8d7c69df84d306c3841bb516213742c4a0a43c2f3d6b39ce6e163d6d77f45f8 Test-Command-0.11.tar.gz
+"