aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-test-easy/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/perl-test-easy/APKBUILD')
-rw-r--r--community/perl-test-easy/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/community/perl-test-easy/APKBUILD b/community/perl-test-easy/APKBUILD
new file mode 100644
index 00000000000..3563ece2131
--- /dev/null
+++ b/community/perl-test-easy/APKBUILD
@@ -0,0 +1,40 @@
+# Automatically generated by apkbuild-cpan, template 1
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=perl-test-easy
+_pkgreal=Test-Easy
+pkgver=1.11
+pkgrel=0
+pkgdesc="facilitates easy testing patterns"
+url="http://search.cpan.org/dist/Test-Easy/"
+arch="noarch"
+license="GPL PerlArtistic"
+cpandepends="perl-functional-utility perl-data-denter perl-hash-mostutils perl-test-resub perl-data-difflet"
+cpanmakedepends=" "
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/B/BE/BELDEN/$_pkgreal-$pkgver.tar.gz"
+
+_builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+}
+
+build() {
+ cd "$_builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ make
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="72cf55e3846a87fa0505d9e75611da3e Test-Easy-1.11.tar.gz"
+sha256sums="1e8935ddc125be7c1eaab144a12dbf84d5dde3552f4912fcdd2dcede5eabf25d Test-Easy-1.11.tar.gz"
+sha512sums="cbcaa726183de305881023f21bd33c752f4d0a732d49ac8ba8d43798204b73774f802d57c5da342e31a543230bf225e1f725c700c334a1b6c5a475b933035e77 Test-Easy-1.11.tar.gz"