aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-test-mock-guard/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/perl-test-mock-guard/APKBUILD')
-rw-r--r--community/perl-test-mock-guard/APKBUILD18
1 files changed, 7 insertions, 11 deletions
diff --git a/community/perl-test-mock-guard/APKBUILD b/community/perl-test-mock-guard/APKBUILD
index 91b5f7becda..9306213cb83 100644
--- a/community/perl-test-mock-guard/APKBUILD
+++ b/community/perl-test-mock-guard/APKBUILD
@@ -1,39 +1,35 @@
# Contributor: Stuart Cardall <developer@it-offshore.co.uk>
# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
pkgname=perl-test-mock-guard
-_pkgname=Test-Mock-Guard
+_pkgreal=Test-Mock-Guard
pkgver=0.10
-pkgrel=4
+pkgrel=5
pkgdesc="Simple mock test library using RAII"
url="https://github.com/zigorou/p5-test-mock-guard"
arch="noarch"
license="PerlArtistic"
-depends="perl-class-load perl-exporter"
-makedepends="perl-dev perl-module-build"
+depends="perl perl-class-load perl-exporter"
+makedepends="perl-module-build"
subpackages="$pkgname-doc"
-source="https://cpan.metacpan.org/authors/id/X/XA/XAICRON/$_pkgname-$pkgver.tar.gz"
-builddir="$srcdir/$_pkgname-$pkgver"
+source="https://cpan.metacpan.org/authors/id/X/XA/XAICRON/Test-Mock-Guard-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
default_prepare
- cd "$builddir"
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
perl Build.PL --installdirs=vendor
}
build() {
- cd "$builddir"
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
./Build
}
check() {
- cd "$builddir"
- ./Build test
+ ./Build test
}
package() {
- cd "$builddir"
./Build install --destdir="$pkgdir"
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}