aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-tie-cycle/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/perl-tie-cycle/APKBUILD')
-rw-r--r--community/perl-tie-cycle/APKBUILD35
1 files changed, 18 insertions, 17 deletions
diff --git a/community/perl-tie-cycle/APKBUILD b/community/perl-tie-cycle/APKBUILD
index 40f302a442e..b0582291983 100644
--- a/community/perl-tie-cycle/APKBUILD
+++ b/community/perl-tie-cycle/APKBUILD
@@ -1,37 +1,38 @@
-# Automatically generated by apkbuild-cpan, template 1
+# Automatically generated by apkbuild-cpan, template 4
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=perl-tie-cycle
-_pkgreal=Tie-Cycle
-pkgver=1.226
+pkgver=1.228
pkgrel=0
-pkgdesc="Cycle through a list of values via a scalar."
+#_pkgreal is used by apkbuild-cpan to find modules at MetaCpan
+_pkgreal=Tie-Cycle
+pkgdesc="Cycle through a list of values via a scalar"
url="https://metacpan.org/release/Tie-Cycle/"
arch="noarch"
-license="GPL-1.0-or-later OR Artistic-1.0-Perl"
+license="Artistic-2.0"
depends="perl"
subpackages="$pkgname-doc"
-source="https://cpan.metacpan.org/authors/id/B/BD/BDFOY/$_pkgreal-$pkgver.tar.gz"
+source="https://cpan.metacpan.org/authors/id/B/BD/BDFOY/Tie-Cycle-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
-check() {
- make test
-}
-
-prepare() {
- default_prepare
+build() {
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL \
+ INSTALLDIRS=vendor \
+ NO_PACKLIST=1 \
+ NO_PERLLOCAL=1
+ make
}
-build() {
+check() {
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
- make
+ make test
}
package() {
make DESTDIR="$pkgdir" install
- find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-sha512sums="74097ea346efd3217e076fee5fec2bcbcd1c0165f6b94c435e022e7aafa581d5b17f2c03768e351c2e404d067b064984c595d7d53b20f5b16e6874c22228ad4e Tie-Cycle-1.226.tar.gz"
+sha512sums="
+6ff75e2b6fe13860127dc75f127fd840ed5f2ee95f5173de494b0f6fd42862b9b2b33d05930bcdaa14e3647ad8c0e87e6f488108a01d301c01ef0df384f5ec31 Tie-Cycle-1.228.tar.gz
+"