aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-tie-cycle/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/perl-tie-cycle/APKBUILD')
-rw-r--r--community/perl-tie-cycle/APKBUILD45
1 files changed, 19 insertions, 26 deletions
diff --git a/community/perl-tie-cycle/APKBUILD b/community/perl-tie-cycle/APKBUILD
index c21f5e717cf..b0582291983 100644
--- a/community/perl-tie-cycle/APKBUILD
+++ b/community/perl-tie-cycle/APKBUILD
@@ -1,45 +1,38 @@
-# Automatically generated by apkbuild-cpan, template 1
+# Automatically generated by apkbuild-cpan, template 4
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=perl-tie-cycle
+pkgver=1.228
+pkgrel=0
+#_pkgreal is used by apkbuild-cpan to find modules at MetaCpan
_pkgreal=Tie-Cycle
-pkgver=1.225
-pkgrel=2
-pkgdesc="Cycle through a list of values via a scalar."
+pkgdesc="Cycle through a list of values via a scalar"
url="https://metacpan.org/release/Tie-Cycle/"
arch="noarch"
-license="GPL PerlArtistic"
-cpandepends=""
-cpanmakedepends=" "
-depends="$cpandepends"
-makedepends="perl-dev $cpanmakedepends"
+license="Artistic-2.0"
+depends="perl"
subpackages="$pkgname-doc"
-source="https://cpan.metacpan.org/authors/id/B/BD/BDFOY/$_pkgreal-$pkgver.tar.gz"
+source="https://cpan.metacpan.org/authors/id/B/BD/BDFOY/Tie-Cycle-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
-check() {
- cd "$builddir"
- make test
-}
-
-prepare() {
- default_prepare
-
- cd "$builddir"
+build() {
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL \
+ INSTALLDIRS=vendor \
+ NO_PACKLIST=1 \
+ NO_PERLLOCAL=1
+ make
}
-build() {
- cd "$builddir"
+check() {
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
- make
+ make test
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
- find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-sha512sums="68822821a6bb5475bef7bfdb6775a876aaac6afead5b79b0bd1365f99eb1bf4430a5ae97b8e124f66fd4cbef2b4095df526c85d2d9240b0750bfae6af3c9f75e Tie-Cycle-1.225.tar.gz"
+sha512sums="
+6ff75e2b6fe13860127dc75f127fd840ed5f2ee95f5173de494b0f6fd42862b9b2b33d05930bcdaa14e3647ad8c0e87e6f488108a01d301c01ef0df384f5ec31 Tie-Cycle-1.228.tar.gz
+"