aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-tie-hash-method/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/perl-tie-hash-method/APKBUILD')
-rw-r--r--community/perl-tie-hash-method/APKBUILD16
1 files changed, 4 insertions, 12 deletions
diff --git a/community/perl-tie-hash-method/APKBUILD b/community/perl-tie-hash-method/APKBUILD
index 930160944c1..e50d5b04ee4 100644
--- a/community/perl-tie-hash-method/APKBUILD
+++ b/community/perl-tie-hash-method/APKBUILD
@@ -4,40 +4,32 @@
pkgname=perl-tie-hash-method
_pkgreal=Tie-Hash-Method
pkgver=0.02
-pkgrel=3
+pkgrel=4
pkgdesc="Tied hash with specific methods overriden by callbacks"
url="https://metacpan.org/release/Tie-Hash-Method/"
arch="noarch"
-license="GPL PerlArtistic"
-cpandepends=""
-cpanmakedepends=" "
-depends="$cpandepends"
-makedepends="perl-dev $cpanmakedepends"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
+depends="perl"
subpackages="$pkgname-doc"
source="https://cpan.metacpan.org/authors/id/Y/YV/YVES/$_pkgreal-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
default_prepare
-
- cd "$builddir"
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
- cd "$builddir"
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
make
}
check() {
- cd "$builddir"
- make test
+ make test
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}